Difference between revisions of "Plasma/Coinstallability"

Jump to: navigation, search
(kwin)
(updates)
 
Line 1: Line 1:
Plasma 2014.6 is a whole new version and won't co-install with Plasma 1.  Nevertheless some parts of runtime should co-install so apps using kdelibs4 can run under Plasma Next.
+
Plasma 5 is a whole new version and won't co-install with Plasma 1.  Nevertheless some parts of runtime should co-install so apps using kdelibs4 can run under Plasma 5.
  
 
[[Frameworks/Coinstallability|Frameworks Coinstallability page]]
 
[[Frameworks/Coinstallability|Frameworks Coinstallability page]]
Line 5: Line 5:
 
= not co-installable =
 
= not co-installable =
  
these overlap with KDELibs 4 equivalents from kde-workspace, no change expected
+
these are new version of the KDELibs 4 equivalents from kde-workspace and won't co-install, no change expected
  
 
* libksysguard
 
* libksysguard
Line 15: Line 15:
 
* khelpcenter
 
* khelpcenter
 
* powerdevil
 
* powerdevil
 +
* plasma-desktop
 +
* plasma-workspace
  
= kde-cli-tools =
+
= yes co-installable =
clashing files with kde 4's kde-runtime:
 
https://git.reviewboard.kde.org/r/117884/
 
  
= kwin =
+
* kwin is now co-installable
 
+
* baloo libraries are co-installable but not the binaries (although they are drop in replacements)
No reason why this needs to co-install but Martin asked.
+
* kfilemetadata co-installable library version
Clashing files with kde4 kwin:
 
 
 
* /usr/bin/kwin (due to be renamed?)
 
* /usr/lib/x86_64-linux-gnu/libkdecorations.so
 
* /usr/share/doc/HTML/en/kcontrol/windowspecific
 
 
 
= Oxygen =
 
 
 
* liboxygen/ clashes and should be renamed  https://git.reviewboard.kde.org/r/117770/
 
* kstyle/ oxygen-settings and oxygen-demo should be renamed  DONE
 
* cursors/ all clash and should be renamed (or removed, why do we ship multiple cursors?) https://git.reviewboard.kde.org/r/117856/
 
* kwin-decorations/ oxygen-shadow-demo should be renamed  https://git.reviewboard.kde.org/r/117773/
 
* sounds/ should all be renamed https://git.reviewboard.kde.org/r/117775/
 

Latest revision as of 16:00, 30 June 2014

Plasma 5 is a whole new version and won't co-install with Plasma 1. Nevertheless some parts of runtime should co-install so apps using kdelibs4 can run under Plasma 5.

Frameworks Coinstallability page

not co-installable

these are new version of the KDELibs 4 equivalents from kde-workspace and won't co-install, no change expected

  • libksysguard
  • ksysguard
  • kinfocenter
  • kmenuedit
  • kwrited
  • systemsettings
  • khelpcenter
  • powerdevil
  • plasma-desktop
  • plasma-workspace

yes co-installable

  • kwin is now co-installable
  • baloo libraries are co-installable but not the binaries (although they are drop in replacements)
  • kfilemetadata co-installable library version

This page was last edited on 30 June 2014, at 16:00. Content is available under Creative Commons License SA 4.0 unless otherwise noted.