Thread titleRepliesLast modified
Merge with Get Involved/development?120:38, 25 July 2020
fanciful: "Compilation: how to quickly solve build problems"216:18, 3 May 2020
Build dependencies for kdevplatform necessary?402:29, 8 September 2016
grantlee 5.0 in Debian sid / Qt 5.4220:13, 18 December 2015
Isn't Phonon4Qt5 needed on openSUSE?109:30, 9 August 2015
unable to finish Qt 5.2 compilation unless it is done in a different directory100:14, 6 February 2014
KF5 build error kdex.dtd100:13, 6 February 2014
Qt5 and KDE Frameworks003:24, 16 September 2012

Merge with Get Involved/development?

There is currently overlapping information here and on Unfortunately it also seems that some information is only available on either page making it necessary to read both. This is not ideal and the current structure does not make it easy to understand how the information is linked together. I suggest to merge the information so there is one single point of truth to refer to. Probably it makes sense to keep this site and link to here from Get Involved/development. That way there wouldn't be so much detail info on that page and one is not overwhelmed when looking to how to get involved easily.

10:49, 20 July 2020

I agree. I've been incrementally migrating content to for years. I guess it's time for me to finally finish that work.

20:38, 25 July 2020

fanciful: "Compilation: how to quickly solve build problems"

What is quick about an 8 step preocedure where you then have to "Start over from scratch." ?? KDE should be more serious about any "convoluted" development process. These problems cannot be wished away with some hipster lingo.

08:36, 11 March 2019

We don't usually use private messages on the wiki, but anyway, I'm not sure about what you are referring to exactly.

08:47, 22 March 2019

You do not have permission to edit this page, for the following reason:

The action you have requested is limited to users in one of the groups: Users, Administrators, trusted, KDEDevelopers.

You can view and copy the source of this page.

Return to Thread:Talk:Guidelines and HOWTOs/Build from source/fanciful: "Compilation: how to quickly solve build problems"/reply (2).


Build dependencies for kdevplatform necessary?

Hi out there, this is my first successful attempt to build KDE components (KDevelop, as described in the tutorial)

I followed the tutorial and got stuck at 2 points: In Kubuntu 15.10 the following packages are missing:

* bison
* flex

Seems that they are not standard in this distro. I added them to the dependencies list in the wiki.

The second thing was that I had to include the build-depencencies for kdevplatform:

  • $ kdesrc-build --include-dependencies kdevplatform

After that, the tutorial worked as described. Should this be added to the tutorial?

I would like to contribute something to this great project in the future (I'm using KDE since some years now and did some C++/Qt4 stuff in the past, beginning with Qt5 now).

So I also would like to see the "obstacles" as low as possible for anyone who wants to get involved as a "bloody beginner" like me.

Risc (talk)13:29, 17 July 2016

I added flex and bison to openSUSE 42.1.

The wiki messaging system is not used often, so if you need further help, please contact the KDE people using the mailing lists or IRC, see

gregormi (talk)11:34, 6 September 2016

I think the following command should either replace or be added to the build command in this doc: $ kdesrc-build --include-dependencies kdevplatform This should help resolve any new dependencies that changed since the writing of the doc.

Donnguyen (talk)14:36, 6 September 2016

I am not sure why specifically kdevplatform should be added to the kdesrc-build argument. Please ask this question on [email protected] It has a much higher visibility than this wiki communication channel.

gregormi (talk)14:50, 6 September 2016

My mistake...I meant to say kdevelop as this was what the instructions were trying to build. However, the recent edits have covered this point. I'll move over to [email protected] or irc if there's still more needed to be discussed.

Donnguyen (talk)02:29, 8 September 2016

grantlee 5.0 in Debian sid / Qt 5.4

I am building KDE Frameworks in Debian SID. There is an error while building kdevplatform because grantlee5 is not found.

Message in the cmake logfile: Could not find a package configuration file provided by "Grantlee5"

I searched the Debian experimental repository and could not find it.

As a solution, I downloaded and installed grantlee-5.0.0.tar.gz from (click on

Now kdevplatform is built just fine.

Tuxolinux (talk)00:12, 23 March 2015

Thanks for the report. Sorry for the late reply. I didn't check the wiki messages. Did you edit the wiki page to reflect your findings?

gregormi (talk)09:32, 9 August 2015

Sorry now for my late reply... I did not update the wiki about grantlee. In fact I could not complete the rest of the building at the time. I am going to try building KF5.17 in Debian Testing now. If there is anything that is not reflected in the wiki and I succeed the building, I'll share it here and on the wiki. Regards!

Tuxolinux (talk)20:13, 18 December 2015

Isn't Phonon4Qt5 needed on openSUSE?

On openSUSE 13.1 I have this for knotifications:

Could not find a package configuration file provided by "Phonon4Qt5"

Isn't this needed?

$ sudo zypper in libphonon4qt5 phonon4qt5-backend-gstreamer phonon4qt5-backend-vlc phonon4qt5-devel
Jstaniek (talk)21:08, 19 May 2015

Sorry for the late reply. I didn't check the wiki messages. Did you solve your problem?

gregormi (talk)09:30, 9 August 2015

unable to finish Qt 5.2 compilation unless it is done in a different directory

I've been unable to compile Qt5 for a long time, until today that I've tried to build it from another directory, not from the git clone directory.

Instead of

$ git clone git:// --branch stable
$ cd qt5
$ ./init-repository
$ ./configure -prefix $PWD/qtbase -opensource -confirm-license -developer-build -nomake tests -nomake examples -dbus -no-separate-debug-info -xcb -qpa xcb -no-gtkstyle
$ make

I had to use:

$ git clone git:// --branch stable
$ cd qt5
$ ./init-repository
$ mkdir build
$ ../configure -prefix $PWD/qtbase -opensource -confirm-license -developer-build -nomake tests -nomake examples -dbus -no-separate-debug-info -xcb -qpa xcb -no-gtkstyle -no-warnings-are-errors
$ make
Jtamate (talk)12:31, 15 December 2013

Works for me whenever I try it, but anyway this is a question for the Qt guys (e.g. #qt-labs on irc). You need to specify the error message in any case, otherwise one can only guess (or can't, actually).

Dfaure (talk)00:14, 6 February 2014

KF5 build error kdex.dtd


 I would like to build KF5, but I've got error and I don't know, what with this. Could anybody help, please. Error message:

Built target klanguagebuttontest_automoc man-preparetips.1.docbook:5: warning: failed to load external entity "dtd/kdex.dtd" ]>


man-preparetips.1.docbook:7: parser error : Entity 'language' not defined <refentry lang="&language;">


man-preparetips.1.docbook:7: validity error : Validation failed: no DTD found ! <refentry lang="&language;">

Tomas (talk)08:45, 22 December 2013

You need to export XDG_DATA_DIRS to your installprefix/share.

Dfaure (talk)00:13, 6 February 2014

Qt5 and KDE Frameworks

Did something change within Frameworks to make this document out of date for KDE Frameworks on QT5?

I try to pass -DQT5_BUILD=TRUE as the document states, and now recently I am getting

CMake Warning:

 Manually-specified variables were not used by the project:

and ldd on the resulting binaries seems that it builds against QT4 in /usr, instead of the QT5 in /opt. The same buildscript I use used to work.

N3rdopolis (talk)03:21, 16 September 2012

This page was last edited on 10 March 2016, at 16:24. Content is available under Creative Commons License SA 4.0 unless otherwise noted.