Plasma/Coinstallability

< Plasma
Revision as of 13:07, 2 June 2014 by Mgraesslin (talk | contribs) (kwin)
Jump to: navigation, search

Plasma 2014.6 is a whole new version and won't co-install with Plasma 1. Nevertheless some parts of runtime should co-install so apps using kdelibs4 can run under Plasma Next.

Frameworks Coinstallability page

not co-installable

these overlap with KDELibs 4 equivalents from kde-workspace, no change expected

  • libksysguard
  • ksysguard
  • kinfocenter
  • kmenuedit
  • kwrited
  • systemsettings
  • khelpcenter
  • powerdevil

kde-cli-tools

clashing files with kde 4's kde-runtime: https://git.reviewboard.kde.org/r/117884/

kwin

No reason why this needs to co-install but Martin asked. Clashing files with kde4 kwin:

  • /usr/bin/kwin (due to be renamed?)
  • /usr/lib/x86_64-linux-gnu/libkdecorations.so
  • /usr/share/doc/HTML/en/kcontrol/windowspecific

Oxygen


Content is available under Creative Commons License SA 4.0 unless otherwise noted.