GSoC/2017/StatusReports/chinmoyrp

Jump to: navigation, search

Polkit Support in KIO

Running Qt GUI applications as root is dangerous. Some KDE applications are disabling being executed as root. For example, the next versions of Dolphin and Kate will show an error message and exit when started with root privileges. Polkit is the library made specifically to solve such problems. It is the standard framework used by Linux desktops to grant privileged actions to unprivileged processes. The goal of this project is to add Polkit support in KIO, the library used by KDE applications to manipulate the filesystem.

Work Report

=Brief

  • What's working with elevated privileges

1. File Cut/Copy/Paste 2. File/Folder delete 3. Rename File 4. Create New File/Folder/Link 5. Undo 6. Drag and Drop

  • What's not working with elevated privileges

1. Mass Rename 2. Copying locked folders i.e., folders without the search permission. 3. Listing contents of a locked folder 4. Trashing files 5. Creating archives

Code

Blog Posts

Proposal


Content is available under Creative Commons License SA 4.0 unless otherwise noted.