Difference between revisions of "Amarok/GettingStarted/Dependencies"

Jump to: navigation, search
(Required: remove reference to the Kollide server)
(Optional: add mention of testing being enabled by default in KDE)
 
Line 47: Line 47:
 
** The official downloader should work fine on Windows, too. But it's broken on many Linux systems.
 
** The official downloader should work fine on Windows, too. But it's broken on many Linux systems.
 
* Building tests require:
 
* Building tests require:
** gmock 1.4 (or newer) - http://code.google.com/p/googlemock/
+
** gmock 1.4 (or newer) - http://code.google.com/p/googlemock/ Beware, gmock has to be compiled separately for Amarok to work. Currently KDE has tests enabled by default, to circumvent this, one needs to use the following cmake argument: -DKDE4_BUILD_TESTS=OFF
  
  

Latest revision as of 11:42, 4 December 2014

DEPENDENCIES

Required

Optional


Please note that if compiling from source you also need to install -dev/-devel versions of these packages, depending on your distribution.


This page was last edited on 4 December 2014, at 11:42. Content is available under Creative Commons License SA 4.0 unless otherwise noted.