Difference between revisions of "Amarok/Development/KF5port"

(create page, add links)
 
(Addition of new Qt5/KF5 Dependencies)
Line 1: Line 1:
 
This page is meant as a guide to port Amarok to Qt5/Frameworks5 and Plasma5.
 
This page is meant as a guide to port Amarok to Qt5/Frameworks5 and Plasma5.
 +
 +
The commits containing the ongoing port of Amarok to Qt5/KF5 are present in this [http://quickgit.kde.org/?p=clones%2Famarok%2Faroonavm%2Famarok_frameworks.git personal repository].
 +
 +
If you would like to build it then you have to install the following packages (apart from the existing dependencies like Taglib, zlib, googlemock, etc ) containing the following components for your respective system :
 +
 +
Qt5::Core
 +
 +
Qt5::DBus
 +
 +
Qt5::Widgets
 +
 +
Qt5::Test
 +
 +
Qt5::Gui
 +
 +
Qt5::Svg
 +
 +
Phonon4Qt5
 +
 +
KF5::CoreAddons
 +
 +
KF5::Solid
 +
 +
KF5::Codecs
 +
 +
KF5::I18n
 +
 +
KF5::ThreadWeaver
 +
 +
KF5::KDELibs4Support
 +
 +
This list has been kept dynamic to avoid pulling unwanted dependencies which means more components will be added when the need arises.
 +
 +
The broad plan involves the porting of the code-base to compile by using KF5::KDELibs4Support. After this the plan involves porting Amarok away from KF5::KDELibs4Support.
 +
We are still in the first part now i.e the current aim is to let Amarok compile by using KF5::KDELibs4Support(with LOTS and LOTS of depreciated warnings).
  
 
Some references:
 
Some references:

Revision as of 11:32, 1 June 2015

This page is meant as a guide to port Amarok to Qt5/Frameworks5 and Plasma5.

The commits containing the ongoing port of Amarok to Qt5/KF5 are present in this personal repository.

If you would like to build it then you have to install the following packages (apart from the existing dependencies like Taglib, zlib, googlemock, etc ) containing the following components for your respective system :

Qt5::Core

Qt5::DBus

Qt5::Widgets

Qt5::Test

Qt5::Gui

Qt5::Svg

Phonon4Qt5

KF5::CoreAddons

KF5::Solid

KF5::Codecs

KF5::I18n

KF5::ThreadWeaver

KF5::KDELibs4Support

This list has been kept dynamic to avoid pulling unwanted dependencies which means more components will be added when the need arises.

The broad plan involves the porting of the code-base to compile by using KF5::KDELibs4Support. After this the plan involves porting Amarok away from KF5::KDELibs4Support. We are still in the first part now i.e the current aim is to let Amarok compile by using KF5::KDELibs4Support(with LOTS and LOTS of depreciated warnings).

Some references:


This page was last edited on 1 June 2015, at 11:32. Content is available under Creative Commons License SA 4.0 unless otherwise noted.