Build of dolphin fails

Jump to: navigation, search

Hi, I have followed these instructions successfully until the build dolphin step. I am using a brand new KDE Neon install in a VM.

I have tried three times over the past four weeks, with the same failure each time. I point it out because it is a bit demoralising :(

The error is kdesrc-build dolphin --include-dependencies

...

<<< PACKAGES FAILED TO BUILD >>> gpgme - ~/kde/src/log/2019-08-15-01/gpgme/build.log frameworkintegration - ~/kde/src/log/2019-08-15-01/frameworkintegration/build.log

The following modules have failed to build 3 or more times in a row:

       gpgme

Since my setup is completely vanilla, I hope this is trivially reproducible. I can't find any recommended source of help for such a problem, hence I post here.

this error may be meaningful:

ibtool: link: g++ -g -O2 -Wall -Wextra -Wno-shadow -o t-keylist t-keylist.o t-support.o -Wl,--disable-new-dtags ../../cpp/src/.libs/libgpgmepp.so ../src/.libs/libqgpgme.so ../../../src/.libs/libgpgme.so -L/home/tim/kde/qt5/lib -L/home/tim/kde/usr/lib /home/tim/kde/usr/lib/libgpg-error.so /home/tim/kde/qt5/lib/libQt5Test.so /home/tim/kde/qt5/lib/libQt5Core.so -lstdc++ -Wl,-rpath -Wl,/home/tim/kde/build/gpgme/lang/cpp/src/.libs -Wl,-rpath -Wl,/home/tim/kde/build/gpgme/lang/qt/src/.libs -Wl,-rpath -Wl,/home/tim/kde/build/gpgme/src/.libs -Wl,-rpath -Wl,/home/tim/kde/usr/lib -Wl,-rpath -Wl,/home/tim/kde/qt5/lib -Wl,-rpath -Wl,/home/tim/kde/usr/lib -Wl,-rpath -Wl,/home/tim/kde/qt5/lib ../src/.libs/libqgpgme.so: undefined reference to `qt_version_tag@Qt_5.12'

07:45, 15 August 2019

Please use the Forum at https://forum.kde.org or the kde@kde.org mailing list for support questions, the wiki is meant as a resource only

09:11, 16 August 2019