Get Involved/development/Install the dependencies

From KDE Community Wiki

If you have any trouble getting things to build due to missing 3rd-party package dependencies, read on to learn what to do. If you need help, see

Missing binary packages per operating system

Fedora KDE 40

kdesrc-build --initial-setup fails with error: Error: Unable to find a match: qaccessibilityclient-devel

Packages to install: qaccessibilityclient-qt6-devel.

How to install the dependencies of one package

KDE neon, Debian, Ubuntu, Kubuntu

Enable deb-src apt package repositories. All the build packages known by the package you want to build can be installed by running:

sudo apt build-dep <package you want to build>

For example, to install the build dependencies for Dolphin, run:

sudo apt build-dep dolphin


If dependencies are missing for a specific RPM package, you can run:

sudo dnf builddep <name_of_rpm_package>

For example, to install the build dependencies for Dolphin, run:

sudo dnf builddep dolphin


Generally you can install the required -devel packages that are needed to build some KDE software from source by using zypper (as root, or by using sudo), e.g. to install the -devel packages required to build dolphin from source:

# zypper --plus-content repo-source source-install --build-deps-only dolphin

replace dolphin with some other package name, e.g. to build ktexteditor from source:

# zypper --plus-content repo-source source-install --build-deps-only ktexteditor

Note that the --plus-content option in the above commands means you don't need to have the source repository enabled all the time, --plus-content will make zypper temporarily enable it to get the info it needs.

openSUSE (and most other RPM-based Linux distributions) support cmake() BuildRequires, which means you can install a development package like so:

# zypper install 'cmake(KF5KIO)'

the part between the parenthesis KF5KIO is going to be in the error message that CMake will print in the terminal if you try to build something that requires e.g. KIO if KIO development headers aren't installed.

Any other dependencies can be figured out and installed as you continue building the modules one by one. For instance, to build Dolphin or Kate, you will need need to also run:

# zypper install libassuan-devel makeinfo graphviz-gd

Fix CMake Error

If you run kdesrc-build in order to build a KDE git repository. And if building fails with a CMake error. Then, that is most often caused by the fact that you do not have installed some binary packages from your Linux OS.

See below for some ideas about how to find out what Linux packages you need to install.

Missing pkgconfig or cmake

If the CMake error looks like:

Build-time dependency gi-docgen found: NO (tried pkgconfig and cmake)

docs/api/ ERROR: Dependency "gi-docgen" not found, tried pkgconfig and cmake

The error here is that CMake could not find the pkgconfig named "gi-docgen" (most probably a file with the extension".pc") or the CMake file (most probably a file with the extension".cmake") that contains "gi-docgen" case insensitively in name.


  • Maybe we can find the correct package name.
# Is there an rpm package with the name "gi-docgen" installed?
rpm -qa gi-docgen
# It is not installed.

# Is there in the package repositories an rpm with name containing "gi-docgen"?
dnf search gi-docgen
# Returns:
# Last metadata expiration check: ...
#============================================================================== Name #Exactly Matched: gi-docgen #==============================================================================
#gi-docgen.noarch : Documentation tool for GObject-based libraries
#============================================================================= Name & #Summary Matched: gi-docgen #=============================================================================
#gi-docgen-doc.noarch : Documentation for gi-docgen
#gi-docgen-fonts.noarch : Metapackage providing fonts for gi-docgen output

# Install the rpm gi-docgen
dnf install gi-docgen
  • Look for the .pc or .cmake file in the content of all rpm files in all of the enabled package repositories.
dnf repoquery -l gi-docgen
# Returns:

dnf install gi-docgen
  • DNF knows how to install the rpm that contains a given pkgconfig file.
dnf provides 'pkgconfig(gi-docgen)'
# Returns:
#gi-docgen-2023.1-9.fc39.noarch : Documentation tool for GObject-based libraries
#Repo        : fedora
#Matched from:
#Provide    : pkgconfig(gi-docgen) = 2023.1
sudo dnf install 'pkgconfig(gi-docgen)'

Missing executable

If the CMake error looks like:

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find Sass (missing: Sass_EXECUTABLE)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:600 (_FPHSA_FAILURE_MESSAGE)
  cmake/modules/FindSass.cmake:48 (find_package_handle_standard_args)
  CMakeLists.txt:31 (find_package)

The error here is that CMake could not find the executable named "sass" (most probably a file "/usr/bin/sass").


  • DNF knows which rpm contains a given executable.
dnf provides sass
# Returns:
#rubygem-sass-3.7.4-7.fc39.noarch : A powerful but elegant CSS compiler that makes CSS fun again
#Repo        : fedora
#Matched from:
#Filename    : /usr/bin/sass
sudo dnf install rubygem-sass

Debian/Kubuntu/KDE neon

E.g. I am on Kubuntu 22.10, kdesrc-build frameworks fails, module kcoreaddons has CMake (configure) error Could NOT find Qt6LinguistTools (missing: Qt6LinguistTools_DIR).

Option 1:

Search on the internet for ubuntu packages Qt6LinguistTools it returns Expand "amd64 [list of files]": /usr/lib/x86_64-linux-gnu/cmake/Qt6LinguistTools/Qt6LinguistToolsConfig.cmake

sudo apt install qt6-tools-dev

Option 2:

sudo apt install apt-file
sudo apt-file update
apt-file find Qt6LinguistToolsConfig.cmake
# qt6-tools-dev: /usr/lib/x86_64-linux-gnu/cmake/Qt6LinguistTools/Qt6LinguistToolsConfig.cmake
# Or
apt-file search -i Qt6LinguistTools
# All results are from the package qt6-tools-dev e.g.:
# qt6-tools-dev: /usr/lib/x86_64-linux-gnu/cmake/Qt6LinguistTools/Qt6LinguistToolsConfig.cmake

sudo apt install qt6-tools-dev

If the error is:

The imported target "Qt6::qtwaylandscanner" references the file
but this file does not exist.


apt-file find /usr/lib/qt6/libexec/qtwaylandscanner
# qt6-wayland-dev-tools: /usr/lib/qt6/libexec/qtwaylandscanner
sudo apt install qt6-wayland-dev-tools

Option 3:

apt search linguist | grep qt6
# linguist-qt6/kinetic 6.3.1-2 amd64
sudo apt install linguist-qt6

More examples:

# Error "Could not find OsmTools (missing: OSMCONVERT_EXECUTABLE
apt-file search -i OSMCONVERT
# Returns "osmctools: /usr/bin/osmconvert".
sudo apt install osmctools
# Error "Program doxygen found: NO
# doc/ ERROR: Program 'doxygen' not found or not executable"
apt-file search doxygen | grep "/doxygen$"
#doxygen: /usr/bin/doxygen
#polymake-common: /usr/share/polymake/scripts/doxygen
sudo apt install doxygen


E.g. if the error is:

Failed to find required Qt component "LinguistTools".

Expected Config file at
"/lib64/cmake/Qt6LinguistTools/Qt6LinguistToolsConfig.cmake" does NOT exist


sudo dnf install 'cmake(Qt6LinguistTools)'

You can also search by file:

dnf provides */Qt6LinguistToolsConfig.cmake
# qt6-qttools-devel-6.5.1-1.fc38.i686 : Development files for qt6-qttools
# Repo        : updates
# Matched from:
# Filename    : /usr/lib/cmake/Qt6LinguistTools/Qt6LinguistToolsConfig.cmake


In order to be able to run sudo pkg edit the file ~/.profile, uncomment the line:

PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:$HOME/bin; export PATH

Reboot the computer.

E.g. xmlto executable is missing:

pkg search xmlto
# xmlto-0.0.28                   Front-end to an XSL toolchain
pkg install xmlto

Error makeinfo: not found WARNING: 'makeinfo' is missing on your system.:

pkg install pkg-provides

Uncomment the following lines in /usr/local/etc/pkg.conf file and add pkg-provides to the supported plugin list:

PKG_PLUGINS_DIR = "/usr/local/lib/pkg/";
PLUGINS [ provides ];
pkg plugins
# NAME       DESC                                          VERSION   
# provides   A plugin for querying which package provides a particular file 0.7.3 
pkg provides -u
pkg provides bin/makeinfo
# Name    : texinfo-7.0.3,1
# Comment : Typeset documentation system with multiple format output
Repo    : FreeBSD
# Filename: usr/local/bin/makeinfo
pkg install texinfo